Jump to content
IGNORED

Xbox Series S|X hardware impressions


Fusty Gusset
 Share

Recommended Posts

22 minutes ago, Fusty Gusset said:

Just arrived! Happy launch day folks!

F4023BF0-B33E-4417-A4EB-EFD414C09015.jpeg

 

I'd never really registed the boxart before; if I ever win the lottery I'll be sure to buy one of those for my trypophobe friend. You know, see if I can push them over the edge.

Link to comment
Share on other sites

Feeling pretty fancy setting this up. From the tabs on the sticky tape on the outside of the box to the little set-up instructions card that stands up on its own, to the textured grip and triggers/bumpers on the new controller, it really feels like MS have thought the whole thing through.

 

A very nice thing to experience day one. The little chonker even looks like it's floating a little because of the circular stand.

 

Happy next gen day!

Link to comment
Share on other sites

Wired up both Xboxs to the router and network transfer about 450Mbps now. Not as fast as it should be but certainly about 5 times faster than download. Unfortunately I didn't have Forza 4 downloaded on the old one so will have to download that.

Link to comment
Share on other sites

1 hour ago, pinholestar said:

Any other lucky Series X owners getting insanely fast download speeds on this thing? I didn’t even realise my internet was capable of such speeds. :blink:

 

Also, as a returner to the Xbox fold and a newcomer to Game Pass, this is me right now:

 

image.gif.72974d61fb86463bf08e5fdf17fe240a.gif

I’m getting the complete opposite. Initial patch came down quick now I’m getting between 1-8Mbps for updates to games, this is wired. However my Xbone is getting 20-30Mbps over wireless at the moment downloading D2.

 

Doing a speed test on the XsX is reporting 1MBps! Really fucking annoying as it’s reporting days to do upgrades. I was always getting 35-45Mbps on my Xbone when directly wired in.

 

Hoping a router reboot will help but my Wife is working at the moment so have to wait.

 

Very much dampening my enthusiasm as I feel I’m not going to get to play an upgraded game till Thursday at this rate.

Link to comment
Share on other sites

10 minutes ago, CovisGod said:


Im pretty sure I read it was an known issue and they’re working on a fix

Yep, found eurogamer article, should be fixed soon. Found AppleTV app in the search but didn't appear in the basic app listing in the store.

Link to comment
Share on other sites

14 minutes ago, KRP said:

I can't believe how massive and heavy it is, feels premium. Just about fits under the TV too!

 

NB my gf came and said "what the hell is that! That is not staying there." - she thought the cardboard box was the console...

Screenshot_20201110-131300~2.jpg

 

I can feel it staring at me, watching every move and waiting for me to slip up.

Link to comment
Share on other sites

I can’t get over how much smaller the Series X is than I was expecting. Thought it would be much larger. Looks really nice even horizontally and is super quiet. Just completed set up and now installing Forza Horizon 4. Looking forward to 4K 60FPS Horizon after work.

 

Enjoy everyone!

Link to comment
Share on other sites

Can’t play anything I want to try as they all require updates/upgrades and for some reason I’m getting fuck all download speed. Connection test (wired) shows 2Mbps down and 0.6Mps up. Xbone on wireless reports 35Mbps down and 17Mbps up.

 

No idea what is going on, tried the XsX on wireless and that made no difference. Really spoiling the day after the console arrived so early,

Link to comment
Share on other sites

4 minutes ago, metallicfrodo said:

Can’t play anything I want to try as they all require updates/upgrades and for some reason I’m getting fuck all download speed. Connection test (wired) shows 2Mbps down and 0.6Mps up. Xbone on wireless reports 35Mbps down and 17Mbps up.

 

No idea what is going on, tried the XsX on wireless and that made no difference. Really spoiling the day after the console arrived so early,

 

Probably servers getting hammered on launch day.

Link to comment
Share on other sites

3 minutes ago, AceGrace said:

 

Probably servers getting hammered on launch day.

Then why is the Xbone happily downloading D2 update while exactly the same thing on the X is crawling (and why would connection test return different results).

 

To be fair I assume it’s my router doing something but what that is I don’t know.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.