Jump to content
IGNORED

MiSTer: FPGA gaming


Dr_Dave
 Share

Recommended Posts

Is this the only place to get the main set of Mister files (to use with the installation tool above)? The download stops short and leaves me with corrupt files, unfortunately.

 

Edit: no worries - earlier the SD install tool was saying "Update package incorrect", but I've managed to add the latest release from that page to the same folder and it now says "Boot + Files", which I think is what I want.

 

Ed: damn, update_all.sh and downloader.sh are still just showing me the main menu when I try to start them...

Link to comment
Share on other sites

Yeah, I'm only connected via wifi but it usually works fine. The behaviour of the scripts is currently unpredictable - update_all stopped booting me back to the main menu and downloaded most of the arcade games (which all seem to work!), but it got stuck at eswat.mra and needed a restart, after which it has been stopping at this screen again. Guess I'll just keep tinkering! Thanks again for the suggestions, all.

 

Edit: PSX core is now showing a black screen on (attempted) startup, too. I think I have the .rbf and the BIOS files (boot.rom etc) in the right places, so I'm not sure what I've broken this time! 😛

 

Link to comment
Share on other sites

It might be worth trying to hook up the MiSTer to your network by ethernet cable as I know wi-fi can be a bit flakey with the MiSTer.

 

Must confess I'm not really sure what to suggest at this point other than setting up again with a fresh install. As well as the link you gave earlier, which is my preferred method for setting up a fresh SD card, you could also try the "Mr-Fusion" method for setting up a fresh install as well which seems to have become the favoured method for setting up.

 

 

Link to comment
Share on other sites

Cheers - I'll definitely give the Mr-Fusion method a try. These current issues are all happening after a fresh installation - the 'mame-getter' problem is the same as before, sadly. I'll see if using an ethernet cable helps, too. :)

Link to comment
Share on other sites

Everything's working again! Plugging in an ethernet cable and giving the updater a couple of hours helped it to push through and download everything, and the PSX core stopped giving me a black screen of its own volition, with no further changes on my part. Thanks again for the advice, everyone!

 

Edit: a save file from the last build - "Alundra (USA).sav" - won't load on the new one, even though it is mounted in memory card slot 1 and labelled correctly, etc. The game just freezes upon trying to load it. I think I'm using the same version of the BIOS and everything. Oh well, I love it enough to play through the first half again. :D

Link to comment
Share on other sites

I'm perhaps imagining things and I've done an awful lot of reading things about the MiSTer over the last couple of months so I'm struggling to find it now in my history, but I'm sure I saw something about a .ini file that would make update_all create console listings under their Japanese names.

 

I'm not a weeb or anything, but it bothers me more than it perhaps should when I see Turbografx instead of PC Engine in particular, but I always also had Japanese consoles in the 16bit days so it would be really nice to see Super Famicom instead of SNES and Mega Drive instead of Genesis etc too. 

 

Can anyone point me in the right direction of this or any other way of accomplishing this whilst retain the update_all functionality?

 

Thanks.

Link to comment
Share on other sites

Oh Christ, I'm a buffoon. There wasn't a problem with the PSX saves at all - I just hadn't set up my controller properly after the reinstallation, and was missing a confirm button! (I realised this when I tried to load a Policenauts save couldn't get it to even attempt to read the card.)

Link to comment
Share on other sites

Ooh that’s nice. What’s the overall quality like? Would you mind sharing a link to the one you bought? 
 

I’m quite happy with the acrylic smoke grey case I bought from misterfpga.co.uk but I could be tempted to upgrade next time I order some 8Bitdo controllers from AliExpress. 

Link to comment
Share on other sites

Finally found the spare 1 minute required to get Mr Fusion to expand.


My MiSTer currently looks like this..


IMG_0953.thumb.jpeg.591e65b9ac0e26134e2a0ad2af138635.jpeg
 

 

Need to pick up an OTG hub and I’m done.. well, other than my plans for a custom case. 
 

Edit: decided to just go with the official powered hub from OzMisterMods.

Link to comment
Share on other sites

On 09/06/2022 at 18:11, SuperFamiTom said:

Ooh that’s nice. What’s the overall quality like? Would you mind sharing a link to the one you bought? 

It's this one:

https://m.aliexpress.com/item/1005003531497871.html

I have to say it's really good quality, very well designed and nice and sturdy. Comes with all screws and spacers you need, even a screwdriver lol

Careful though I needed to change my IO board USB hub to a new version as my old one didn't fit the case..

Link to comment
Share on other sites

11 hours ago, pastry said:

Finally found the spare 1 minute required to get Mr Fusion to expand.


My MiSTer currently looks like this..


IMG_0953.thumb.jpeg.591e65b9ac0e26134e2a0ad2af138635.jpeg
 

 

Need to pick up an OTG hub and I’m done.. well, other than my plans for a custom case. 
 

Edit: decided to just go with the official powered hub from OzMisterMods.

If you haven't bought the hub yet I have my old one that I could sell for cheaps :eyebrows:

Link to comment
Share on other sites

4 hours ago, roobarb said:

It's this one:

https://m.aliexpress.com/item/1005003531497871.html

I have to say it's really good quality, very well designed and nice and sturdy. Comes with all screws and spacers you need, even a screwdriver lol

Careful though I needed to change my IO board to a newer version as my old one didn't fit the case..


Which IO board did you switch to?

Link to comment
Share on other sites

15 hours ago, Vimster said:

Also does it need the right sort of hub? This image is on the page:

 

 

 

Ucf4a894d0ba54999b673f6b7ba16346bp.jpg

Yes it needs the new one on the left.. I failed to check this and therefore needed to upgrade my old version IO board USB hub.

The hubs come with the necessary power and bridge connectors, at least mine did.

Link to comment
Share on other sites

3 hours ago, roobarb said:

Yes it needs the new one on the left.. I failed to check this and therefore needed to upgrade my old version IO board.


So what you really mean is you had to update your USB hub? The IO board is what you’d normally find a VGA port on.

 

Good call either way. I’m on the old one (despite just being over a year old). Is this new one powered by that USB port? I’m going to have to change my power cable splitter if so.

 

misterfpga.co.uk don’t seem to be soldering any with nine ports yet.

Link to comment
Share on other sites

10 hours ago, Fallows said:


So what you really mean is you had to update your USB hub? The IO board is what you’d normally find a VGA port on.

 

Good call either way. I’m on the old one (despite just being over a year old). Is this new one powered by that USB port? I’m going to have to change my power cable splitter if so.

 

misterfpga.co.uk don’t seem to be soldering any with nine ports yet.

Yes that's what I really meant..  doh. :rolleyes:

USB hub not IO board

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.