Jump to content
IGNORED

MiSTer: FPGA gaming


Dr_Dave
 Share

Recommended Posts

2 hours ago, Colonel Panic said:

I've been debating getting a second one so I can have one in my arcade cabinet and the other connected to a TV for console games. 

 

Me too actually. Its a way off, but an ambition of mine. I was maybe gonna start a separate thread about discussing this? (as I have absolutely no idea what to buy, what the best is etc..) I thought either a custom cab, with a rollerball and perhaps sticks that twist, and four controllers to support Ninja Turtles (when that eventually turns up), or something like an astro city.

Link to comment
Share on other sites

It's definitely worth it if you have the space and money, @Tomdominer. I bought one just over a year ago during lockdown insanity, but I love it.

 

My personal preference is Japanese candy cabs versus the kind of custom cabs you see today. It's all about the big CRT screen and sit down form factor for me. I was in honeymoon in Japan a few years ago and my poor wife watched me lose my mind over candy cabs everywhere.

 

I think enough people have cabinets to make a thread looking for advice worth it. 

Link to comment
Share on other sites

Can anyone tell me what i change if i'm going to use a RGC scart with analogue IO board?

 

Not going into anything fancy just a bog standard CRT.

 

Also is there a way of quick switching between .ini files so i can jump between CRT and LCD with changing it everytime?

Link to comment
Share on other sites

2 hours ago, bwi said:

I've set the comp sync but i seem to have a really dark screen in black and white. I can just about make out the mister menu.

 

Any ideas?

 

Anything else i need to set?

What cable are you using and are you sure that the TV is capable of running at 60khz?

Link to comment
Share on other sites

33 minutes ago, Colonel Panic said:

That sounds like a TV trying to display a composite image, @bwi, but there isn’t any data to display. 
 

Can you cycle through inputs on your TV to one that’s RGB? 

 

It does indeed seem that the cable isn't switching to RGB mode.

 

Is this a cable resistor mod or something to fix.

 

 

 

Link to comment
Share on other sites

16 hours ago, Tomdominer said:

 

Me too actually. Its a way off, but an ambition of mine. I was maybe gonna start a separate thread about discussing this? (as I have absolutely no idea what to buy, what the best is etc..) I thought either a custom cab, with a rollerball and perhaps sticks that twist, and four controllers to support Ninja Turtles (when that eventually turns up), or something like an astro city.

 

Before you even consider the form factor (the machine or controls) come up with a list of games it has to play, and maybe an extension list of games it would be nice  play. If you do this (and be pragmatic about it), the machine will almost specify itself and then it just comes down to your budget and how much (if any) you want to DIY yourself.

 

Don't end up on the crapmame subreddit!

Link to comment
Share on other sites

1 hour ago, bwi said:

 

It does indeed seem that the cable isn't switching to RGB mode.

 

Is this a cable resistor mod or something to fix.

 

 

 

 

1 hour ago, bwi said:


Hard to tell without seeing the inside of the SCART head. There is supposed to be a jumper on the analogue IO board that delivers 5V to the VGA output as well. 

Link to comment
Share on other sites

Just enabled wifi so I could run 'update_all', and got a message saying I needed switch 'fb_terminal' to '0' or 'vga_scaler' to '1'. I figured the latter would mess with the sync on my CRT, so I tried the former, and got another message saying it couldn't show the settings screen because fb_terminal needs to be set to 1. However, it carried on anyway and is now downloading 'release_20210711' (it's been about 5 mins - no idea how big the file is or how long it should take). Is this going to be alright, or do I need to do something to stop that message about fb_terminal from coming up?

 

Cheers!

 

Edit: it ran through every system that needed updating (most said "nothing to update"), and has seemingly finished that process without issue. Now extracting 'media/fat/linux' something or other.

 

Edit: now downloading a bunch of new .mra files, including Esprade! But also saying "MAME version not listed" a lot...

Link to comment
Share on other sites

7 hours ago, bwi said:

 

It does indeed seem that the cable isn't switching to RGB mode.

 

Is this a cable resistor mod or something to fix.

 

 

 

 

Ok just placing this here.

 

I decided to throw the +5v down the VGA port via the jumper. It flicked to RGB straight away, but also put it into 16:9.

Changing to +3v switches to RGB and leaves it in 4:3

 

Thanks to everyone that chimed in to help :)

Link to comment
Share on other sites

By the way, does having an .mra file in two places stop it from working? (I believe roms can't be in two places? At least according to some jotego installation notes.) I ask because a lot of the arcade stuff that currently isn't working for me happens to be in both the root '__Arcade' folder and one of the alphabetically organised folders.

 

Edit: hmm, never mind - Fever SOS only seems to boot up at all when it's in both folders, albeit with the same rolling sync issue as before, followed by a black screen...

 

Edit: managed to get the Japanese version of Progear working, but without sound! Qsound.zip is in my MAME folder, too. Most CPS2 games still just give a black screen, despite the roms being in the right place (games/mame). I've changed the Jotego settings to allow beta stuff to be installed, and ran update_all, so the core should have everything it needs. Pretty stumped, but there's still plenty of other stuff to play!

Link to comment
Share on other sites

Jotego's instructions aren't the best. I remember winging my CPS2 and Qsound installations to get them to work.

 

I'll post screens of my folders later if no one does it before me. I'm away from my desk today.

Link to comment
Share on other sites

Cheers! I appreciate the help. But don't go out of your way - I'm happy to keep digging. Here are some pics of my folder structure (most of which was in place when the Mister arrived), in case anyone notices anything iffy:

 

Root folder

Arcade

CPS2

games/mame

 

And the CPS2 core itself, updated from whatever I had installed during the update_all process.

 

As far as I'm aware, the .mra files in the arcade folder should be able to find the roms in the games folder (as is the case for every other arcade and console core I've tried so far), and I'm pretty sure I have all the right roms (update_all is supposed to fill in any gaps for you, too), so I'm still not sure what's going on. I have managed to figure out that my Qsound file is an outdated one, though, so I should at least be able to fix Progear's music soon. :)

 

Edit: Hyper SFII (15th anniversary one), Dimahoo, VSav, Powered Gear and Cyberbots are all working now, but again without sound. I currently have both the old qsound.zip and qsound_hle.zip in the mame roms folder (dl-1425.bin was the missing file). Checked the audio jack on the RGB SCART cable and it all seems fine.

 

Ed: putting the contents of qsound_hle.zip into qsound.zip seems to have fixed the audio! Now to figure out why AvP isn't booting, while the rest are...

Link to comment
Share on other sites

On 16/07/2021 at 01:04, roobarb said:

Latest addition! Just waiting for a MiSTer to be plugged into it :D

PXL_20210715_190628282.jpg

 

That's funny....that looks an awful lot like the Trinitron I sold on Facebook to a guy who said he planned to use it with a MiSTer 😉

 

Hope it serves you well! If I'd known you were a forumite I'd have let you leave with my son's bag of old toys that he tried to offer you as well 😆

Link to comment
Share on other sites

20 minutes ago, donkeyk said:

 

That's funny....that looks an awful lot like the Trinitron I sold on Facebook to a guy who said he planned to use it with a MiSTer 😉

 

Hope it serves you well! If I'd known you were a forumite I'd have let you leave with my son's bag of old toys that he tried to offer you as well 😆

No way! :D

At least you know I wasn't talking BS!

Cheers by the way.. looks great after a cleanup

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.