Jump to content
IGNORED

My 360 is dead


robdood
 Share

Recommended Posts

Ok, so, I get home from work tonight, have a smoke and feel like some Ridge Racer 6.

I boot up the machine on my spanky new HDTV, and get a route plotted. Begin the first race, all is going well. Suddenly, the screen freezes; the game/360 seems to have crashed. Ah well.

Reboot; same thing happens, as soon as I start racing, the game freezes again. Uh oh. Except this time there are crazy lil white squares randomly scattered about.

Shit!

Reboot again. Have a feel and check of the wires, everything seems secure... This time, the 360 crashes during the opening FMV of Ridge, and the screen is decorated (completely) green. Lovely!

Fuckity fuck!

Panicking, I decide to do the First Rule. Remove and reconnect all wires! And FUCK! The AV cable is not in properly! Thank fuck!

But no.

I start playing Ridge again. I got to play for longer this time. I finished the first race. But then, during the start of the replay..

VegetaCharge.jpg

Please, please. Someone make this better. GoW is out this fucking Friday, and I've just bought a HDTV :(

What makes 360s go wrong? Hold me!

(And yes, I know I should get a blog and this is the 'worst I got a HDTV thread ever)

Link to comment
Share on other sites

Oh I forgot to add; after the Super Saiyajin-enducing final crash, the next boot crashed on the 360 Logo :( But no red lights :(

It still boots now, seems happy on the dashboard. I've turned it off out of fear now tho :(

Link to comment
Share on other sites

That's exactly what mine did before dying. Angel's suggestion is definitely what I would try first, take it back and hope you get a nice/stupid assistant. Failing that, its prolly a couple of weeks before you are gonna see it again if you are lucky from MS. Gutting timing man :(

Link to comment
Share on other sites

Jesus, I really had no idea this was happening to people a lot. How on earth was the bloody console allowed to ship, when this happens to it? People here saying they've had two, even four, consoles break on them.

Astounding scenes. I'll not be joining Wii60, then. Just Wii.

Link to comment
Share on other sites

Ok, well my housemate suggested I try turning the video down to see if it'd work in 480p.. It forced itself to 50hz too, for some reason, but now I've managed to finish 2 races.

Very odd.

I've turned it off again, will try again, back in 720p in about 20mins.

Eeesh, now to find the receipt, just incase!

Link to comment
Share on other sites

Move the 360 to a cooler well ventelated place.

No.

Get a replacement ASAP. It's dying and whilst you can prolong it's life by taking all sorts of steps, it will still die. Only it will probably die out of warranty, leaving you with a £280 doorstop.

Take it back to the shop or call Microsoft ASAP.

Link to comment
Share on other sites

Yeah, seems its fucked. Managed to play the Lost Planet demo for 30mins, before deciding everything was fine again (now with the window next to the 360 shelf thingy open :( ) it literally crashed just before I pressed the power switch :(

Then it fucked up on the 360 logo boot sequence.

Back to GAME with it then, in time for Friday! Sheesh. How very annoying. :(

Link to comment
Share on other sites

Hmmm.. Well I only bought it 4 months ago-ish, so it isn't a launch one.

Does it make sense that maybe, somehow, using the hidef modes on the 360 could overheat it? I know it's ridiculous, but still..

.::: If you're brave enough. Stick Dead Rising in it and let it run on the title-screen for half an hour. DR is pretty intensive at some points. If that causes something, than I'm afarid it's simply waiting for it to die entirely.

My condolences though, it's only downhill from here. :(

Link to comment
Share on other sites

Precisely the same problem as my launch 360 developed earlier this year - it was tempting to believe it was temporary but, as I'd secretly suspected, one or more components had fried and eventually it was back to Microsoft.

If the return-to-shop policy doesn't get you anywhere, is it any consolation that MS got a replacement to me in 4 days? :(

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.